HDOJ4190 Distributing Ballot Boxes #贪心 二分#

↘锁芯ラ 提交于 2020-02-04 23:57:35

Distributing Ballot Boxes

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2571    Accepted Submission(s): 1340

Problem Description

Today, besides SWERC'11, another important event is taking place in Spain which rivals it in importance: General Elections. Every single resident of the country aged 18 or over is asked to vote in order to choose representatives for the Congress of Deputies and the Senate. You do not need to worry that all judges will suddenly run away from their supervising duties, as voting is not compulsory.
The administration has a number of ballot boxes, those used in past elections. Unfortunately, the person in charge of the distribution of boxes among cities was dismissed a few months ago due to nancial restraints. As a consequence, the assignment of boxes to cities and the lists of people that must vote in each of them is arguably not the best. Your task is to show how efficiently this task could have been done.
The only rule in the assignment of ballot boxes to cities is that every city must be assigned at least one box. Each person must vote in the box to which he/she has been previously assigned. Your goal is to obtain a distribution which minimizes the maximum number of people assigned to vote in one box.
In the first case of the sample input, two boxes go to the first city and the rest to the second, and exactly 100,000 people are assigned to vote in each of the (huge!) boxes in the most efficient distribution. In the second case, 1,2,2 and 1 ballot boxes are assigned to the cities and 1,700 people from the third city will be called to vote in each of the two boxes of their village, making these boxes the most crowded of all in the optimal assignment.

Input

The first line of each test case contains the integers N (1<=N<=500,000), the number of cities, and B(N<=B<=2,000,000), the number of ballot boxes. Each of the following N lines contains an integer ai,(1<=ai<=5,000,000), indicating the population of the ith city.
A single blank line will be included after each case. The last line of the input will contain -1 -1 and should not be processed.

Output

For each case, your program should output a single integer, the maximum number of people assigned to one box in the most efficient assignment.

Sample Input

2 7 200000 500000 4 6 120 2680 3400 200 -1 -1

Sample Output

100000 1700

Source

Recommend

lcy

Solution

// Version 1 暴力模拟
#include <bits/stdc++.h>
using namespace std;

typedef long long ll;
typedef pair<int, int> p;
const int maxn = 5e5 + 10;
int ple[maxn], box[maxn];
priority_queue<p> q;

int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("input.txt", "r", stdin);
#endif
    std::ios::sync_with_stdio(false);
    int n, m;
    while (cin >> n >> m)
    {
        if (n == -1 && m == -1) break;
        while (!q.empty()) q.pop();
        for (int i = 1; i <= n; i++)
        {
            cin >> ple[i];
            q.push(p(ple[i], i));
            box[i] = 1;
        }
        for (int i = 0; i < m - n; i++)
        {
            p now = q.top();
            q.pop();
            int id = now.second;
            int num = (int)ceil((double)ple[id] / ++box[id]);
            q.push(p(num, id));
        }
        cout << q.top().first << endl;
    }
    return 0;
}
// Version 2 二分
#include <bits/stdc++.h>
using namespace std;

typedef long long ll;
const int maxn = 5e5 + 10;
int n, m, a[maxn];

bool check(int x)
{
    int sum = 0;
    for (int i = 1; i <= n; i++) sum += (int)ceil(1.0 * a[i] / x);
    return sum <= m;
}

int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("input.txt", "r", stdin);
#endif
    std::ios::sync_with_stdio(false);
    while (cin >> n >> m)
    {
        if (n == -1 && m == -1) break;
        for (int i = 1; i <= n; i++) cin >> a[i];
        int l = 0, r = 5e8;
        while (l < r)
        {
            int mid = (l + r - 1) >> 1;
            if (check(mid)) r = mid;
            else l = mid + 1;
        }
        cout << l << endl;
    }
    return 0;
}

 

标签
易学教程内所有资源均来自网络或用户发布的内容,如有违反法律规定的内容欢迎反馈
该文章没有解决你所遇到的问题?点击提问,说说你的问题,让更多的人一起探讨吧!