题解:Abiyoyo(水题)

99封情书 提交于 2019-12-06 03:39:00

“Abiyoyo, Abiyoyo.” “Abiyoyo, Abiyoyo.” “Abiyoyo, yo yoyo yo yoyo.” Once upon a time there was a little boy, who played a ukulele. He’d go around town: clink, clunk, CLONK! Of course, the grownups would be busy, and they would say: “Take that thing out of here. We are talking. Git!” And they would kick him out of the house. Now, in this town they used to tell stories. The old people used to tell stories about the monsters and giants that lived in the old days! They used to tell a story about Abiyoyo. They said he was as tall as a house, and could eat people up. Of course, nobody believed it, but they told the stories anyway. But one day, the sun rose, blood red over the hill, and the first people that got up and looked out of their window. They saw a great big shadow in front of the sun, and they could feel the whole ground shake. Women screamed. Strong men fainted. They said: “Run for your lives! Abiyoyo’s coming!” Down through the fields he came. He came to the sheep, pasture and grabs a whole sheep. Yeowp! He eats it down in one bite. He comes to the cow pasture. Yuhk! Justthentheboywokeup. Theboyrubbedhiseyesandsaid: “Hey, whatiscomingoverthefields? Oh, it is Abiyoyo.” He grabbed his ukulele. Over the fields he went, right up to where Abiyoyo was. People screamed “Don’t go near him! He will eat you alive!” There was Abiyoyo. He had long fingernails because he never cut them. He had slobbery teeth because he never brushed them. Matted hair because he never combed it. Stinking feet because he never washed them. He was just about to come down with his claws, when the boy whipped out his ukulele. Abiyoyo, Abiyoyo Abiyoyo, Abiyoyo Abiyoyo, yo yoyo yo yoyo Abiyoyo, yo yoyo yo yoyo. Well, the monster had never heard a song about himself before, and a foolish grin spread across his face. And started to dance. Abiyoyo, Abiyoyo. The boy went faster. Abiyoyo, yo yoyo, yo yoyo Abiyoyo, yoyo yoyo, ho ho ho ho ho ho ho ho. The giant got out of breath. He staggered. He fell down flat on the ground. “Booooom!” A hunter fired, and the Abiyoyo died. People streamed out of their houses, and ran across the fields. They sang many times: Abiyoyo, Abiyoyo. Then they all sang: Abiyoyo, yo yoyo yo yoyo. Abiyoyo, yo yoyo yo yoyo.
Input
This problem has several test cases. The first line of the input contains an integer t (1 ≤ t ≤ 20) which is the number of test cases. Then t cases follow. For each test, a line contains an integer k (1 ≤ k ≤ 20) which means that people sang k times: Abiyoyo, Abiyoyo.
Output
For each case, output all what they sang after the death of Abiyoyo in several lines.
Sample Input
3
2
5
1
Sample Output
Abiyoyo, Abiyoyo.
Abiyoyo, Abiyoyo.
Abiyoyo, yo yoyo yo yoyo.
Abiyoyo, yo yoyo yo yoyo.
Abiyoyo, Abiyoyo.
Abiyoyo, Abiyoyo.
Abiyoyo, Abiyoyo.
Abiyoyo, Abiyoyo.
Abiyoyo, Abiyoyo.
Abiyoyo, yo yoyo yo yoyo.
Abiyoyo, yo yoyo yo yoyo.
Abiyoyo, Abiyoyo.
Abiyoyo, yo yoyo yo yoyo.
Abiyoyo, yo yoyo yo yoyo.

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <math.h>
#include <time.h>
#include <algorithm>
typedef long long ll;
using namespace std; 
int main()
{
 int t,n;
 scanf("%d",&t);
 while(t--)
 {
  scanf("%d",&n);
  for(int i=1;i<=n;i++)
   printf("Abiyoyo, Abiyoyo.\n");
  printf("Abiyoyo, yo yoyo yo yoyo.\n");
  printf("Abiyoyo, yo yoyo yo yoyo.\n"); 
 } 
    return 0;
}
标签
易学教程内所有资源均来自网络或用户发布的内容,如有违反法律规定的内容欢迎反馈
该文章没有解决你所遇到的问题?点击提问,说说你的问题,让更多的人一起探讨吧!