动态路由联通全网

一世执手 提交于 2020-03-31 15:24:22
  1. 需要的环境PacketTracer6(思科)

  2. 对路由器配置动态路由实现不同网段之间的通信
  3. 按要求搭建上面的网络拓扑结构
    使用鼠标拖动将所需要的结构放入到空白处
  4. 配置好各台pc机的ip地址以及网关地址(ip地址以及各网关地址注明在上面)
  5. 对路由器连接的各个端口进行配置,命令如下:

左边路由器:
enable 15
configure terminal
interface fastethernet 0/0(查看端口号使用鼠标移入有连接的颜色的节点)
ip address 222.1.3.2 255.255.255.0
no shutdown 
exit

interface serial 3/0
ip address 222.1.5.2 255.255.255.0
no shutdown 
exit

interface serial 2/0
ip address 222.1.4.2 255.255.255.0
no shutdown 
exit

右边路由器:
enable 15
configure terminal
interface fastethernet 0/0
ip address 222.1.2.5 255.255.255.0
no shutdown 
exit

interface serial 3/0
ip address 222.1.6.2 255.255.255.0
no shutdown 
exit

interface serial 2/0
ip address 222.1.4.1 255.255.255.0
no shutdown 
exit

上边的路由器:
enable 15
configure terminal
interface fastethernet 0/0
ip address 222.1.1.4 255.255.255.0
no shutdown 
exit

interface serial 3/0
ip address 222.1.6.1 255.255.255.0
no shutdown 
exit

interface serial 2/0
ip address 222.1.5.1 255.255.255.0
no shutdown 
exit

  1. 对各个路由器配置动态路由,命令如下:

左边路由器:
enable 15
configure terminal
router rip 
version 2
network 222.1.3.0
network 222.1.4.0
network 222.1.5.0

右边路由器:
enable 15
configure terminal
router rip 
version 2
network 222.1.2.0
network 222.1.6.0
network 222.1.4.0

上边路由器:
enable 15
configure terminal
router rip 
version 2
network 222.1.1.0
network 222.1.5.0
network 222.1.6.0

  1. 查看各个路由器的路由表

为了方便查看,插入上面的网络拓扑结构图:

使用show ip route查看

对于左边的路由器,如果配置正确会显示:

对于右边的路由器,如果配置正确会显示:

对于上边的路由器,如果配置正确会显示:

8.进入PC机的Command Prompt 终端ping各个主机查看联通情况:

进入ip地址为222.1.1.1由近及远ping自己与各个主机

(1)ping 软件回环地址:

(2)ping自己的网卡:

(3)ping其他PC机

  1. 分析第一次ping的时候为什么会丢包或者延时

ping第一个是ARP广播包,建立MAC地址和IP地址对应表

因为一开始不知道对方的MAC地址,所以包可能丢。
————————————————
版权声明:本文为CSDN博主「蠕动的二哈」的原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接及本声明。
原文链接:https://blog.csdn.net/qq_39445165/java/article/details/80559561

易学教程内所有资源均来自网络或用户发布的内容,如有违反法律规定的内容欢迎反馈
该文章没有解决你所遇到的问题?点击提问,说说你的问题,让更多的人一起探讨吧!