Automating MS Word in Server 2012 R2

穿精又带淫゛_ 提交于 2019-12-04 19:34:11


Firstly, please don't reply with the generic advice not to automate Word on a server or a link to the MS web page on "how to automate word on a server if you really must". I am aware of this.

I have a process which runs as a Windows service and uses .Net OLE interop to automate Office (mostly just Open and SaveAs). This code has worked reliably for 8 years on literally hundreds of servers using many combinations of Windows and Office versions, both 32 and 64 bit, so I am happy that the mechanism is reliable. So far...

With Server 2012 R2, it works with PowerPoint and Excel but fails trying to open a word document:

System.Runtime.InteropServices.COMException (0x800A16A0): 
  The file appears to be corrupted.
   at Microsoft.Office.Interop.Word.Documents.Open...

My observations so far which may or may not be relevant:

  • fails on all documents
  • works fine in Windows 8.1
  • the same problem has happened both on a customer site and in our test environment, so is unlikely to be purely environmental
  • my application is using .Net 3.5
  • the code is linked against the 2003 Interop assemblies (obviously later office versions are supported by assembly binding redirection)
  • we have tried it with office 2013 both 32 and 64 bit with the same results, but not tried earlier versions of office
  • it fails whether the service is running as LocalSystem or as a standard user account
  • if we run the service process in the foreground (i.e. literally double-clicking on the executable) the problem does not happen

Obviously I still have things to investigate but interested to hear if anyone else has seen this specific problem even if you haven't solved it. Please note there are many difficulties and problems with office automation so unless your symptoms are very similar to mine, you probably don't have the same problem.


Same issues here but got this fully resolved now.

I have a Word 2013 in combination with Windows 2012 R2 Server running in a service process which does everything I want without the need of a interactive session to be started. I use this to convert documents to PDF files. Inside the Windows service I host a WCF service.

Create folders: (replace System32 with Syswow64 depending of you use x86 or x64 bit edition)

C:\Windows\System32\config\systemprofile\AppData\Local\Microsoft\Windows\INetCac‌he C:\Windows\System32\config\systemprofile\Desktop

Last and most important step!

Start - run - dcomcnfg.exe

Open properties -> Component Services - DCOM Config - Microsoft Word 97 - 2003 Document (Note that the version is not mentioned here but that does not matter Office 2013 will use this as DCOM config)

Open tab Identity. Configure the run as a the local Administrator account. I did some tests Word 2013 will work just fine even if no interactive session is started for the user.


We(My Company) are currently facing the same problem, it is pretty much a carbon copy of your problem. We have completed extensive testing around this area and I am now in talks with MS support engineer trying to find a work around.

Unfortunately this is something they don't want us doing, I think they have tightened security on the Windows Server 2012 to stop people from doing this.

What we have tried which should help you:

  1. Server 2012 | Word 2007 | Failed
  2. Server 2012 | Word 2010 | Failed
  3. Server 2012 | Word 2013 | Failed
  4. Client 8.1 | Word 2013 | Failed

Our problem stems from the fact we are running word with a user who isn't associated with the LOCAL system user(i.e. the type of user you have when you are logged into the machine) Windows will just not allow this to happen anymore.

Myself and the MS Engineer are working on "Fooling" windows into thinking it is running Word as a local service, however the MS Engineer said it was a long shot at best and so far everything we have tried has resulted in failure. It's not looking good.

Sorry I don't have an answer for you, but I suppose its good know you are not alone?


I had the same problem with MsOffice 2010 (32bits) and Windows Server 2012R2 (64bits). Word, Excel, Powerpoint don't work with localAdmin.

I created the folder C:\Windows\System32\config\systemprofile\AppData\Local\Microsoft\Windows\INetCac‌​he like Andy did and it now work perfectly !

Thanks Andy :)


My service use MS Word for data merging and concatenations functions. I'm using Word 2016 on Windows Server 2012 R2 . My log says that Word is opened but when the document is opened is throwed an error.

I've first created all the 4 folder suggested:

C:\Windows\System32\config\systemprofile\AppData\Local\Microsoft\Windows\INetCac‌​he C:\Windows\System32\config\systemprofile\Desktop C:\Windows\SysWOW64\config\systemprofile\AppData\Local\Microsoft\Windows\INetCac‌​he C:\Windows\SysWOW64\config\systemprofile\Desktop

Only after creating the last directory the problem was solved.

I've not used DCOM config; my application use an user account with administration priviledges; there was no need to use LocalSystem account with "interaction with desktop" options.

Thank you.


Thanks for all the help OP and contributors. After creating the INetCache folder it worked out for me. I have done the following to get everything working without an active session(WS2012 R2 / MS Office 2013 64x):

  1. Create a local admin user and log in to setup any printers(printing to file) as well as default word options.
  2. Point the DCOM config identity to the local admin user created.
  3. Create the following file :C:\Windows\SysWOW64\config\systemprofile\AppData\Local\Microsoft\Windows\INetCac‌​he


For some machines you need to run " mmc comexp.msc /32 " to set the DCOM setting for MS Word. I found that we needed to do this when 32 bit version of Word was installed only.


We had a working solution for this for quite some time. However the solution broke when we tried to install it on a fully updated 2012 RTM R2 Server. On a 2016 Server we don't see this issue.

In order to make it work again on Windows 2012 R2 Server and also in a none interactive desktop environment:

Follow these steps!:

Actions to solve the issue on a Windows 2012 Sever R2 which is fully updated by Windows update:

Start - Run - mmc comexp.msc /32

Expand: Component Services – Computers – My Computer – DCOM Config

Search for: Microsoft Word 97 – 2003 Document

RMC – Properties – Go to tab: Identity Set from “The launching user” to “This user”. Use a “local Administrator account” which has once singed in to the server machine and has opened Word at least once in an interactive desktop.

Last step: REBOOT THE SERVER! And use a new document name to test your solution again.

Like known and said in the other answers these folder need to be created and accessible by the calling user (local system) normally or the user you configure in the prev steps.

C:\Windows\System32\config\systemprofile\AppData\Local\Microsoft\Windows\INetCac‌he C:\Windows\System32\config\systemprofile\Desktop C:\Windows\SysWow64\config\systemprofile\AppData\Local\Microsoft\Windows\INetCac‌he C:\Windows\SysWow64\config\systemprofile\Desktop


I've just been going nuts to sort this and have tried numerous solutions. I finally resolved this by changing the Identity to "This User". I then used the account that my app pool ran under and also had to add this user the "Administrators" group..

Phew... hope this helps someone too.