“RA layer request failed: REPORT request failed” during git-svn

℡╲_俬逩灬. 提交于 2019-12-04 19:31:30

问题


I've been trying to Git clone a Google Code SVN repository using the following command:

git svn clone --stdlayout https://wtorrent-project.googlecode.com/svn/ wtorrent-git

It gets as far as r11, then gives the following error message:

r11 = 6e04c0fb14aa3f6ab4d871eeed4a0526dc0e54d8 (refs/remotes/trunk)
RA layer request failed: REPORT request failed on '/svn/!svn/vcc/default': REPORT
of '/svn/!svn/vcc/default': 200 OK (https://wtorrent-project.googlecode.com) at
C:\Apps\msysgit/libexec/git-core\git-svn line 5653

This error message was generated by the latest msysgit (v1.7.8), but I get the same error message from my Gentoo box too.


回答1:


Revision 12 and hence 13, 14 are messed up ( someone added a branch trunk in branches, but later deleted it, and that confuses git-svn). You might want to do:

git svn clone -r 1:11 --stdlayout https://wtorrent-project.googlecode.com/svn/ wtorrent-git
cd wtorrent-git
git svn fetch -r 15:HEAD



回答2:


For what it's worth, I fixed it by switching from cloning from secure HTTP (from SourceForge) to regular HTTP. So instead of cloning https://... I cloned http://. No problems after that.




回答3:


If you are just trying to migrate svn to Git, try SubGit, free download, and documentation. SubGit is a Java implementation, that is useful for both 1-time migrations and for mirroring svn to Git repositories and v.v. SubGit worked for me when git-svn didn't. SubGit works on any platform with the Java JRE. (FYI: If you have the Java JDK, and have set JAVA_HOME make sure the path is correct.). After downloading SubGit, extract the zip file, and enter the bin folder. Then follow the online documentation. A batch file for Windows and a shell file for Mac and Linux are both in the extracted bin folder. For Windows just replace subgit with subgit.bat in the following example:

$ subgit import --svn-url path://to/your/svn/repo GIT_REPO_PATH

This will create a new Git repo at GIT_REPO_PATH from the subversion repo given by the URL. See the documentation for other options such as specifying how you want to map trunk/branches/tags/shelves etc.




回答4:


I had the same error message with a different project (after 50000 revisions). For me it helped to tidy up the git repository and then continue fetching from svn:

$ git gc
$ git svn fetch


来源:https://stackoverflow.com/questions/8451480/ra-layer-request-failed-report-request-failed-during-git-svn

标签

工具导航Map

JSON相关